
1. L'ambiente R
TECNICHE DI ANALISI DI DATI I



Raccomandazioni, raccomandazioni, 
raccomandazioni…

Leggete la dispensa e/o seguite le slide con R 
aperto e rifate CONTESTUALMENTE TUTTI

gli ESEMPI proposti. 

Accompagnate allo studio e alla replica degli 
esempi l ’esecuzione degli ESERCIZI proposti 
nella dispensa e su ELLY, e fateli correggere 

dal docente, SOPRATTUTTO in caso di 
difficoltà.  



L'ambiente R
R è un ambiente per elaborazioni statistiche e rappresentazioni grafiche, gratuito, open

source, versatile e dinamico. Dispone di un pacchetto – base con molte funzionalità,

ampliabili scaricando package ad hoc che aggiungono ulteriori funzioni (analisi, grafici) al

programma.

Chiunque, armato di buona volontà e buone competenze di programmazione, può creare

un proprio package e metterlo a disposizione di tutti. Chi è armato di buona volontà e

medio-basse-nulle competenze di programmazione (noi) potrà scaricare package che

contengono le funzioni utili per le proprie analisi da un archivio dedicato: CRAN

(Comprehensive R Archive Network) contiene i file di sistema da scaricare per installare R i

package e molti file help. L’archivio CRAN è mirrored: sono replicate identiche versioni

dell’archivio su server in tutto il mondo: sceglieremo il CRAN geograficamente più vicino.



Scegliete il vostro sistema 

operativo

Scaricare e installare R: https://cran.r-project.org/



La struttura: 

Console, Script, 

Graph



> indica che R è pronto a ricevere istruzioni: si digita il comando, poi Invio (Enter). 

Per modificare la console: menu 

Modifica/Edit→ Preferenze 

interfaccia

Nella console digitiamo i comandi e vediamo i loro risultati. 

La console

Prompt dei comandi



Per inserire commenti o promemoria: # prima del testo

Se si dimentica #, e in tante altre occasioni, l’output è un error: R si aspetta un

comando, e non riconosce quanto scritto come una sua funzione

I comandi si seguono uno dopo l’altro in Console. 

Se volete tornare ad avere una console pulita, si 

usa la combinazione di tastiera Crl+L, o, nel menu 

Modifica / Edit, si sceglie Pulisci / Clear console:



Lo script
Negli script sono scritte e salvate varie linee di comando. Sono utili, per esempio, quando le 

stesse analisi devono essere fatte più volte.

Per creare un nuovo script, selezionare File→ Nuovo/New script

I comandi sono scritti uno dopo l’altro, senza il 

prompt >. Si possono scrivere promemoria 

utilizzando #:

Si eseguono con Edit→ Esegui / Run all o Esegui/ line or 

selection (in Windows, o con      Edit→ Execute in MacOs

Cliccando con il tasto destro del mouse nello script si

seleziona l’azione :



L’output dei comandi selezionati è stampato nella Console:

Lo script viene salvato

(File→ Salva come o File→ Salva), in 

una cartella / directory a vostro piacere, 

come file di R, con estensione .R

Lo script può essere aperto con il 

menu File→ Open script



Graph
Ai grafici è dedicata una finestra, creata quando in console si produce un grafico.

Ogni grafico si sovrappone ai precedenti. Quindi, se si desidera salvare il grafico, bisogna 

salvarlo (come immagine o, meglio, come .pdf) o copiarlo in un altro file.

Posizionandosi in 

Graph, si attivano in 

File le necessarie 

opzioni



Altre interfacce: 

RStudio e RCommander

Non è assolutamente obbligatorio usare l’una o l’altra, o una e l’altra, o 

né l’una né l’altra: il software è sempre R, e quello che ci interessa è il 

prodotto, non la facciata. Scegliete l’interfaccia che vi pare più coerente

con il vostro stile cognitivo e più produttiva per 

arrivare ai nostri fini, ovvero capire qualcosa da una massa di dati.



L’interfaccia grafica RStudio non fa parte di CRAN: scaricate la versione free 

Desktop: https://www.rstudio.com/products/rstudio/download/. 

RStudio riconosce la versione di R che avrete installato sul vostro computer, e si 

terrà aggiornata. La forma – tipo è quadripartita:

Console

Source: view e 

script

Grafici, help, 

packages...

Environment e History

Console

RStudio



… o nel Menu Tools→ Global Options→ Panel 

Layout è possibile specificare un layout diverso o 

ripristinarlo.

Con l’icona sulla barra dei menu…

Le ampiezze orizzontali e verticali delle

finestre possono essere aumentate o

diminuite posizionando il cursore sul

telaio interno che separa le finestre e

spostandolo.



In Tools→ Global Options→ Appearance

potete specificare zoom, font e varianti di

colore-sfondo molto nerd.



I suggerimenti, gli help e i completamenti sono più ricchi e sensibili al contesto; gli

elementi in coppia come ( ) “ “ [ ] sono inseriti automaticamente digitando il primo.

La console



In Environment salviamo e importiamo 

dataframe e oggetti; cliccando sul 

triangolino, si ottiene una sintetica 

descrizione degli oggetti.

Ogni riga di comando può essere selezionata e richiamata in Console (To Console) o inviata in 

in script (To Source)

Environment e History

Nel foglio History vengono 

registrati, in ordine temporale, 

tutti i comandi della sessione

digitati man mano nella Console,



Per creare nuovi script:

Script

Ricordate di salvarlo!

Per eseguirlo:

Potete anche selezionare il comando nello script e digitare Crl+Invio



Files: cliccate per richiamarli 

Plots: possono essere esportati (Export) e

salvati come immagini (Save as image) o

.pdf(Save as PDF), o copiati e incollati in

altre applicazioni.

Se si creano più grafici nella stessa

sessione, ci si sposta dall’uno altro usando

le frecce

Miscellanea



Packages: contiene l’elenco dei packages a

disposizione; il pacchetto caricato per l’analisi ha un

segno di spunta:

Help: la finestra essenziale…. ☺



Una incredibile quantità di materiale informativo su R e le sue funzioni in generale

(tutorial, forum, articoli dedicati, blog, manuali), perlopiù in inglese ma non solo, è a

disposizione sul web e accessibile con una rapida ricerca per parole chiave su Google o

simili

Con  help(nome della 

funzione) o 

?(nome della funzione) si 

ottengono le informazioni sugli 

scopi della funzione e sui modi per 

applicarla, che sono in realtà parte 

del materiale che viene scaricato 

insieme alla funzione stessa. 

Anche nella tradizionale interfaccia  R c’è possibilità di avere aiuto:



L’interfaccia RCommander è contenuta nel package Rcmdr scaricabile dal sito CRAN.

RCommander

Accertatevi che sia spuntato: 

Per installarlo con R:

Per installarlo con RStudio:



Caricatelo nella sessione di lavoro: si apre una nuova finestra di R, a prima vista un po’

deludente:



Deselezionate “Invia i risultati alla 

console di R”, e definite l’altezza della finestra 

dei risultati, che troverete impostata a zero.

Cliccate su Restart RCommander in fondo alla 

scheda e, al riavvio, troverete la bipartizione della 

finestra.

Menu 
Strumenti→Opzioni

Se vedete solo lo script: gli output delle analisi e i grafici compaiono nella finestra di R o di

RStudio, a seconda di quale abbiate aperto. Per vederli entro RCommander:



Solo per vedere un esempio semplice: il menu Grafici consente

di produrre praticamente tutti i grafici che useremo. Il grafico si

apre in una finestra a parte e può essere salvato o copiato.

Vedremo man mano che faremo operazioni su variabili e analisi come eseguirle con

Rcommander.

TUTTI i comandi eseguiti usando le finestre di dialogo sono stampati nella finestra 

degli script: ciascuno può essere  salvato,  modificato e arricchito a piacere nella 

finestra, ed eseguito  (run) producendo un nuovo output.



Fare “cose” con R: 

oggetti e funzioni

AVVERTENZA PRELIMINARE IMPORTANTE

R è case sensitive: considera una stessa lettera maiuscola e 

minuscola come simboli diversi. 

Attenzione, quindi, perché una delle situazioni più frustranti è trovarsi di 

fronte a una serie di messaggi di errore in cui, nonostante voi siate convinti di 

scrivere il comando corretto, R vi dice che non capisce, perché avete scritto 

“Sum” (fai la somma di) invece di sum, o “mean(età)” (fai la media della variabile 

età) quando il nome della variabile di cui volete la media è “Età”.



oggetto è qualsiasi cosa sia creata in

R: una variabile, un modello, una serie

di variabili. Può essere un singolo

valore, o una serie d’informazioni (gli

output delle analisi). Si distinguono

per tipo (class).

Le funzioni sono le cose che si fanno per

creare o lavorare sugli oggetti. Sono

composte da argomenti, cioè istruzioni.

Spesso servono più argomenti, separati

da , ciascuno dedicato a uno specifico

aspetto.

Oggetti e funzioni sono legati <- (funzione di assegnazione): “all’oggetto Y sono assegnate le 

proprietà della funzione X”. Se preferite, potete pensarlo come “l’oggetto è creato da” :

oggetto <- funzione : “l’oggetto Y è creato dalla funzione X”

Tutto quello che vogliamo R faccia deve essere digitato come comando. I comandi sono, 

in genere, strutturati in due parti: gli oggetti e le funzioni



Vediamo un esempio usando una delle funzioni più semplici, ma più onnipresenti e 

importanti: la funzione c → combine

c unisce in un solo oggetto più elementi: possono essere valori numerici o stringhe di

testo, purché tutti dello stesso tipo. La serie di elementi costituisce un vettore.

Costruiamo il reparto di attacco della squadra Internazionale F.C 2020-2021, unendo più

elementi di testo, ciascuno dei quali rappresenta un argomento di c. Quando gli elementi

del vettore sono stringhe di testo, devono essere tra “ ”

L’oggetto 
“attaccanti”

è creato concatenando i testi “Lukaku”, “Martinez”, “Sanchez”

OGGETTO FUNZIONE



gli elementi sono numeri decimali 
ℝ

numeric

i valori sono numeri interi ℤinteger

ogni elemento identifica un diverso 
gruppo di unità di osservazione

variabili di raggruppamento

factor

TRUE, FALSElogic

gli elementi sono stringhe di testocharacter

data (aaaa/mm/gg)date

numeri complessi ℂ con parti reali e 
immaginariecomplex 

data.frame, matrix, lm, 
htest...Altri

La natura degli 

elementi che 

costituiscono un 

oggetto definisce il 

tipo (class) di oggetto 

/ vettore / variabile. 

I più frequenti per noi:

Per verificare la classe: 

class(oggetto)



Si possono richiamare i comandi usando i tasti Freccia su  (o Freccia giù ) della tastiera.

Per visualizzare l’oggetto: oggetto + 

Invio, oppure print(oggetto), 

oppure (oggetto<-funzione)

Se si applica una funzione 

incompatibile con la classe della 

variabile, R si rifiuta:

NA (Not Available): dato mancante

Per sapere di quanti elementi è composto l’oggetto:

length(oggetto):

Per conoscere l’elemento maggiore e l’elemento 

minore: max(oggetto) e min(oggetto)

Poiché attaccanti è di classe character, R restituisce il primo e l’ultimo elemento in ordine alfabetico; 
se fosse numeric, restituirebbe il valore più grande e il più piccolo. 

Si possono digitare più comandi in 

un’unica riga, separandoli con ;



Le funzioni si applicano a

oggetti per creare altri oggetti:

Possiamo correggere attaccanti eliminando l’elemento “Lukaku”:

L’oggetto 
attaccanti_meno_lukaku

è creato 
da

l'oggetto attaccanti,  in cui 
gli elementi di attaccanti

non devono 
essere uguali a

“Lukaku”

Le [ ] si usano per comandi riferiti alla struttura di oggetti compositi

Cioè: “usa attaccanti senza l’elemento che

segue !=”:!= sta per “non uguale a”.

Torniamo allo status quo, reintegrando 

“Lukaku” e togliendo “Chilosà”:

Possiamo aggiungere un nuovo 

elemento all’oggetto con c:

Modificare gli oggetti



Ogni tipo di oggetto creato può essere salvato e restare disponibile in altre sessioni, purché

ci si ricordi di salvare il workspace, cioè l’area di lavoro che contiene tutti gli oggetti e le

funzioni: File→ Save workspace in un file (R Image) .RData.

Riaprendo R, è caricato il workspace con cui si era conclusa la precedente sessione; si può

cambiare usando File→Load workspace.

Ricordate che potete anche usare gli script per salvare oggetti e funzioni.

Per cancellare gli oggetti non più utili, usate rm (remove): rm(oggetto): attenzione,

l’operazione non è reversibile!

Per conoscere quali oggetti sono stati salvati nel workspace attivo, usate objects(): non

scrivete nulla tra parentesi, e ne avrete l’elenco.

Salvate periodicamente quello che fate durante la sessione e all’uscita: Crl+S

Salvare o eliminare gli oggetti



Le funzioni usate finora sono comprese nei package di base (base, stats, lattice,

MASS, utils...) scaricati e installati con a R.. Per avere a disposizioni altre funzioni, vanno

scaricati i packages (archivi compressi) che le contengono.

✓ In Windows: Menu Packages → Install packages: selezionate un mirror tra quelli

elencati, poi il package (anche più d’uno) nell’elenco alfabetico

✓ In MacOS: Packages & Data → Pages Installer: cliccate su List e scegliete i package che vi

servono, poi su Install selected.

Per installarli con R: install.packages(“package”, dependencies=TRUE)

Oppure, abbiamo già visto:

Aggiungere funzioni a quelle di base



Accertatevi che sia spuntato:

Per installarli con RStudio:

Se non lo caricate, R dirà che non trova la funzione, anche se il package è correttamente

installato: digitate library(nome del package), oppure in Windows: Packages→ Load

package, in MacOs Packages & Data→ Package Manager.

In Rstudio, spuntate il nome del package nell'elenco:

Ogni package va installato una sola volta, ma deve essere caricato nel workspace 

ogni volta che se ne vuole usare una funzione. 



Organizzare i dati: 

dataframe e matrici

I dati possono essere inseriti direttamente in R o importati da 

un fonte esterna. 

Cominciamo con il vedere il primo caso, con pochi dati.



Possiamo combinare attaccanti e goal in una struttura chiamata dataframe: un dataframe è

un array, una struttura tabellare che può contenere variabili anche di classe diversa.

Usiamo data.frame: i suoi argomenti sono il nome scelto per identificare la variabile nel

dataframe e il vettore che ne contiene i dati, uniti da =, per tutte le variabili.

Arricchiamo le informazioni sul reparto di attacco dell’Inter 20-21 con la variabile numerica

Numero di goal in campionato segnati dai tre attaccanti. Niente virgolette, sono numeri:

Attenti all’ordine, se vogliamo associarli ai rispettivi autori

I dataframe

oggetto_dataframe <- data.frame(nome variabile 1= vettore1, nome 

variabile 2 = vettore2,...)



Per visualizzare il dataframe in 

una finestra separata: 

View(dataframe).

argomento logic : se TRUE esegue l’argomento, se FALSE non lo esegue. 

Aggiungiamo un argomento opzionale che indica: “quando inserisci un vettore di classe

string nel dataframe, convertilo in un oggetto di classe factor”: stringsAsFactors=

TRUE / FALSE. Di default, stringsAsFactors è = FALSE.

Nelle versione di R precedenti alla 4.0.0, di default stringAsFactors=TRUE. Quindi, se state

usando una versione vecchia di R, è inutile specificare l’argomento – ma aggiornate R

Useremo in Tecniche di analisi di dati II una diversa struttura in cui ogni riga corrisponde a una singola 
misura (long format)

Ogni riga contiene le osservazioni relative a uno specifico caso

e ogni colonna i dati relativi a una sola variabile: wide format.



fix(dataframe) apre una finestra di editing in cui possono essere corretti i dati nelle

singole celle, modificati i nomi e corretto il tipo delle variabili, aggiunte variabili.

Aggiungiamo la nuova variabile presenze in campionato: digitiamo il nome, specifichiamo 

il tipo e scriviamo i dati nelle cella corrispondenti, ottenendo:

Modificare i dataframe



Vogliamo completare il dataframe aggiungendo (dati ufficiali):

Non possiamo unire le tre variabili a due_variabili con c, che accetta solo oggetti dello

stesso tipo, perché abbiamo:

Invece data.frame non ha problemi a unire oggetti di classe diversa:

Quando i vettori sono uniti in una struttura, oltre al nome acquistano un “cognome”, cioè il

nome del dataframe: “cognome e nome” sono separati da $:

Nome del dataframe
Nome della variabile 

I vettori uniti nel dataframe non sono stati eliminati, ed R li considera oggetti a sé: 

un cambiamento in attacco$presenze non cambierà presenze



cbind(vettore1,vettore2,…) e rbind(vettore1,vettore2,…) creano dataframe

da vettori, matrici o altri dataframe, disponendoli per colonna o per riga. Gli elementi

possono essere di classe diversa, purché abbiano lo stesso numero di colonne o di righe

Creiamo i vettori A, B e C, composti da numeri interi consecutivi: A da 1 a 5, B da 10 a 14, C

da 20 a 24. Invece di c, usiamo i : che indicano a R “usa tutti i valori compresi tra… e…”:

Cbind e rbind



str(oggetto) si applica a più classi di oggetto. Per un dataframe, str dà il numero di

osservazioni e variabili, la loro classe, i primi casi di ogni variabile. In Rstudio, l'informazione

di str è in Global Environment

Descrivere la struttura

Lukaku

Martinez

Sanchez

$attaccante non deve essere factor e

$maglia non è veramente numeric: le

correggeremo. Osserviamo che l’ordine dei

livelli del factor corrisponde all’ordine

alfabetico (Lukaku-Martinez-Sanchez→1-2-3).

In generale, R identifica i livelli secondo il

loro ordine alfanumerico crescente.



summary(oggetto) è una funzione molto versatile: i suoi oggetti sono vettori, modelli

statistici, ecc.

Descrivere con summary

Nei dataframe, summary dà le frequenze per variabili character o factor, e

statistiche per le variabili numeric: minimo e massimo, il 1° e il 3° quartile, mediana e

media. Ripasseremo a breve quartili, mediane e medie.

Frequenza



Nella struttura un elemento è identificato dalla cella che occupa: numero di riga (row)

incrociato con il numero della colonna (column). I comandi che riguardano strutture usano le

parentesi quadre: all’interno delle [ ], il primo elemento indica la riga, il secondo la colonna.

Nel dataframe 

attacco,

qual è il dato nella riga 3 incrociata con la colonna 2?

Per informazioni relative a più righe o colonne consecutive, si usano i :

quali sono i dati delle righe 
comprese tra 1 e 2

nella colonna 2?

In attacco,

nelle colonne comprese tra 2 e 3?

quali sono i dati della riga 3

Descrivere parti della struttura

In attacco,



Per visualizzare tutti gli elementi di una colonna tranne quelli corrispondenti a una o più righe,

oppure gli elementi di una riga tranne quelli corrispondenti a una o più colonne, o gli elementi

dell’intera struttura, tranne gli elementi corrispondenti a una più righe e colonne, si antepone

− al numero di riga / colonna da omettere.

Per operazioni su tutte le righe e/o su tutte le colonne, si lascia libero lo spazio prima della

virgola (“tutte le righe”) o dopo la virgola (“tutte le colonne”): “applica quanto richiesto a 

tutte le righe / a tutte le colonne".

Per dati in righe e/o colonne non consecutive, si usa c:

Mostra i goal di tutti gli attaccanti
Mostra tutte le caratteristiche del solo Lukaku



Altri tipi di oggetti che "contengono" vari altri oggetti sono:

• liste: create da list(oggetto), possono contenere oggetti di classi diversa;

• matrici: create da matrix(variabili, numero di righe, numero di colonne),

devono essere composte da variabili o solo numeriche o solo testuali.

Per cambiare i nomi delle variabili di un dataframe si usa names(oggetto), lo vedremo tra poco 

Liste e matrici

rendimento è creato da una matrice che concatena i vettori goal e assist, fatta da 3 righe e 2 colonne

Possiamo aggiungere i nomi delle variabili con fix, oppure con

colnames(colonna); per le righe, useremmo rownames(riga).

di rendimentoCome nomi 
delle colonne

assegna la concatenazione di "goal" e 
"assist"



Se nella matrice si inseriscono erroneamente variabili di testo e

numeriche, R cambia tutte le variabili numeric in character

Le differenze tra dataframe e matrici sono più profonde, ma per il livello richiesto nell’esame, ci fermiamo qui.

Il tibble, più recente, è usato in package aggiuntivi, ad esempio tibble: è un dataframe

che perde alcune caratteristiche (per esempio, non si cambiano nome e classe delle variabili)

e ne aggiunge altre che possono renderlo più “appetibile” per calcoli complessi.

Vedremo esempi di tibble in qualche funzione di Tecniche 
di Analisi di Dati II

Variabile di classe Date, che impareremo tra poco

I tibble mostrano solo le prime dieci righe e le

colonne che si adattano alla dimensione della

finestra; viene sempre mostrata la loro classe



Lavorare su e con le 

variabili della struttura

Vedremo come cambiare il nome e la classe della variabile, le peculiarità 

delle variabili date e factor, la gestione dei dati mancanti e dei dati 

scorretti, le operazioni tra le variabili.



Possiamo cambiare i nomi delle variabili con fix o con names. Da sola, names restituisce i

nomi degli elementi dell’oggetto; associata a, assegna i nomi agli elementi dell’oggetto.

Il nome $attaccante è ridondante rispetto al nome del dataframe: sono tutti attaccanti.

Rinominiamo questa variabile in “campione”. Per cambiare i nomi delle variabili:

Per conoscere i nomi delle variabili di attacco:

Rinominare le variabili 

Se si cambia il nome di una sola variabile, può essere comodo usare la struttura :

assegna
Come nome del primo elemento della 

struttura attacco L'etichetta di testo "polpetta"

… ma torniamo a definizioni più consone:

names(attacco)<-
c("campione","goal","presenze","minuti","assist","maglia")



$attaccante e $maglia non sono

della classe che ci aspetteremmo:

Per cambiare factor in character dopo aver creato il dataframe, usiamo fix oppure

assegniamo alla variabile as.* : * è sostituibile da qualsiasi classe, come as.numeric,

as.character, as.factor, as.Date, ...

Cambiare la classe delle variabili 

La variabile $maglia è creata trasformando in classe character la variabile $maglia

Ora:



Per correggere valori di cella errati, si può usare fix, oppure assegnare il dato corretto

indicando il valore da sostituire con le coordinate di riga – colonna.

Per esempio, se mai venisse finalmente riconosciuto a Lukaku quel goal che non era in

fuorigioco, correggeremmo i suoi 24 goal scrivendo:

Correggere dati errati



Se si devono fare operazioni su date (ad esempio, calcolare l’età dall'anno di nascita), è

essenziale che la variabile sia correttamente codificata. Gli elementi di un vettore Date

devono essere di tipo aaaa/mm/gg, e sono concatenati combinando as.Date e c:

Aggiungiamola al dataframe:

La classe Date

La variabile nascita è creata trasformando in classe Date la concatenazione di questi elementi



Quando una cella non contiene un dato valido, R lo sostituisce con NA (not available).

Se conoscessimo il numero di assist di tutti gli attaccanti tranne Sanchez, scriveremmo:

Alcune funzioni gestiscono gli NA da sole, altre richiedono istruzioni ad hoc. Per esempio,

chiedendo la media degli assist con NA (mean) senza specificare, otteniamo :

In mean va aggiunta l’istruzione di togliere i dati mancanti prima di eseguire il calcolo: si usa

l’argomento logic na.rm =TRUE [NA remove], in cui TRUE dice a R di rimuovere gli NA

Vedremo man mano come le diverse funzioni gestiscono i dati mancanti, ove necessario.

Gestione dei dati mancanti NA



È possibile convertire un dato errato in NA: dataframe[dataframe== valore]  NA

Crediamo che solo 5 assist vincenti siano un risultato
impossibile per un giocatore di serie A: potrebbe
essere un errore di digitazione. Impossibilitati a
recuperare il vero valore, lo consideriamo missing.

Usiamo which(criterio) [chi è?..] per sapere
qual è la riga con assist == 5

Verifichiamo quanti “5” e quanti “NA” siano presenti in

$assist con table(oggetto), che dà la

frequenza assoluta degli elementi; con l’argomento

opzionale exclude=NULL, R non ometterà alcun dato.

Controlliamo: per sapere quali siano i casi con NA, si usa

which associata alla funzione is.na, che identifica gli

NA: which(is.na(dataframe$variabile)).

Sostituiamo il dato della riga 3 colonna 55 con NA:

Possiamo anche riprovare table:



Prima di proseguire con la teoria, un esercizio:

Create il dataframe “centrocampo” usando le seguenti informazioni:

I centrocampisti sono: Hakimi, Perisic, Vidal, Barella e Brozovic; i loro numeri di maglia

sono: 2, 14, 22, 23, 77. Hanno fatto rispettivamente 7, 4, 1, 3 e 2 goal. Hanno

registrato 37, 32, 23, 36 e 33 presenze in campionato. Hanno giocato rispettivamente

per 2672, 1800, 1142, 2900 e 2584 minuti, facendo 8, 4, 1, 7, e 6 assist vincenti. Sono

nati nei seguenti giorni: 4/11/1998, 2/2/1998, 22/5/1987, 7/2/1997, 16/11/1992.

Nel dataframe, la maglia di gioco e il nome del giocatore devono essere stringhe di

testo.

Nel crearlo, considerate che proseguiremo unendo i due dataframe attacco e

centrocampo in un unico dataframe: questa informazione guiderà in qualche maniera i

criteri che seguirete?

Nelle slide successive illustreremo come fare questa unione tra dataframe, ma in realtà

avete già tutti gli strumenti per sapere come si fa, senza andare a leggere: potete

provare da soli?

Lo script per eseguire tutto quanto richiesto è in fondo alla dispensa, ma è inutile 
andarlo a vedere senza almeno provarci (e riprovarci, e riprovarci ☺)



Avete creato il nuovo dataframe centrocampo: da qui lavoreremo sul dataframe avanti,

composto da attacco e centrocampo uniti da rbind:

Va da sé che per funzionare le variabili dei due dataframe devono essere coerenti tra loro….

Fare operazioni con le variabili 



Attaccanti e centrocampisti vanno assegnati al proprio reparto: creiamo una variabile

factor, con due livelli corrispondenti ai reparti. I livelli dei factor sono numeri, cui

possiamo assegnare etichette. Potremmo generare la sequenza, correttamente ordinata,

delle etichette dei livelli del fattore usando c: 3 "attacco" e 5 "centrocampo".

Ma è meglio: rep(x= cosa da replicare, times= numero di repliche):

Creare variabili factor

Più rapidamente:

D’ora in poi creeremo l'oggetto direttamente come variabile del dataframe:

avanti$reparto<- as.factor(c(rep("attacco", 3), rep("centrocampo", 5)))



Ogni vettore può essere trasformato associandolo a un altro vettore, o a un unico valore

scalare, tramite operatori matematici (+, -, *, /, ecc.) e/o gli operatori logici.

Operatore Cosa fa Operatore Cosa fa

+ Somma oggetti >= Maggiore o uguale a

- Sottrae oggetti == Esattamente uguale a

* Moltiplica oggetti != Non uguale a

/ Divide oggetti !x Non x

^ (o **) Esponente x | y

O / VEL: l’operazione fornisce i valori che 
soddisfano la caratteristica y o la 
caratteristica y, ma anche entrambe,

< Minore di x & y

E / AND: l’operazione fornisce i valori che 
soddisfano sia la caratteristica X sia la 
caratteristica Y, ma non quelli che hanno 
una sola delle due.

<= Minore o uguale a isTRUE(x) Verifica se x è TRUE 

> Maggiore di

Creare o modificare variabili da variabili esistenti



Con molte colonne da sommare, si usa rowSums(dataframe[ ,colonne da sommare]):

Creiamo $rendimento, somma delle azioni finalizzate con successo: goal + assist vincenti.

Visualizziamo solo i primi - head(variabile, n=) e gli ultimi - tail(variabile, n=)

casi; con n= specifichiamo quanti (di default n=6):

Facciamo un’operazione tra un vettore e uno scalare, passando da minuti a ore di gioco:



Rapportiamo il rendimento alle ore di gioco, creando $efficienza

Arrotondiamo a due decimali: round(x=oggetto, digits=numero di decimali):

Attenti alle parentesi.....

Usiamo $nascita per ottenere l’età, calcolabile come quantità di giorni trascorsi da quello

natale alla data di fine stagione, che creiamo; dividiamo $età per 365, per averla in anni:

Il default per round è digits= 0

$eta è di classe difftime, differenza tra epoche, convertiamola in numeric:



Soprattutto in dataframe con molti soggetti e/o molte variabili sarà necessario estrarre parti

di un dataframe per lavorare solo su alcuni casi o su alcune variabili. Si può fare in vari modi.

Si può usare la struttura [riga,colonna]:

nuovo_dataframe  vecchio_dataframe[righe, colonne]

Se non viene specificato nulla dove R aspetta istruzioni su righe o colonne, R le importa tutte

nel nuovo oggetto.

Selezionare parti della struttura

di cui seleziona le 
righe da 4 a 8

Il datafame
centro

è creato dal dataframe 
avanti

e tieni tutte le 
colonne

Solo gli attaccanti:

Goal e presenze dei centrocampisti:



Si può usare subset: nuovo dataframe subset(x=vecchio dataframe,

subset= casi da esportare, select = c (colonna/e da esportare)).

subset= estrae le righe, select= (opzionale) le colonne: di default, sono esportate tutte. I

casi si selezionano con gli operatori logici. In subset= e select= si può omettere il nome del

dataframe prima della variabile, perché è già indicato in x=.

Nomi e goal di chi ha 
segnato almeno 5 goal

Solo i centrocampisti con 
più attitudine al goal

I più giovani o quelli che 
hanno segnato poco

Solo gli attaccanti, 
per esclusione





Per qualsiasi funzione

Se omettete il nome dell’argomento (x=, subset=, ecc.), R si 

aspetta che gli argomenti si succedano nell’ordine previsto 

dalla funzione (nel caso di subset, prima il dataframe, poi il 

criterio di selezione delle righe, infine il criterio di selezione 

delle colonne). 

Se gli argomenti non rispettano quest’ordine, R non trova quello 

che si aspetta e restituisce un errore o un output insensato. 

Invece, se indicate il nome dell’argomento, potete inserirli 

nella funzione in qualsiasi ordine. 



Il menu Dati → Set di dati attivo offre una gran quantità di possibilità di azioni

Lavorare sulla struttura con Rcommander



Il menu Dati → Gestione variabili del set di dati attivo offre altrettante

possibilità di agire sulle singole variabili che lo compongono:

Lavorare sulle variabili con Rcommander



Non ci servirà per l'esame, ma i dataframe creati in R si possono salvare in formati diversi.

Per il formato con valori delimitati da tabulazioni (tab-delimited file) .txt, si usa:

dati<-write.table(dataframe, “nome del file.txt”, sep=“\t”, 

row.names=FALSE):

Non creare una colonna 

con i numeri di riga

Dataframe da 

salvare
Nome del file 

da creare

Il separatore di 

colonna è il tasto Tab

Per salvare il file con valori separati da virgole (CSV: comma-separated values) .csv si usa:

dati <- write.csv(dataframe, “nome del file.csv”)

È salvato nella cartella predefinita, che potete conoscere chiedere con getwd() - get

working directory; non scrivete nulla tra (). Per cambiarla, usate setwd() - set working

directory -specificando tra le parentesi il nuovo percorso, o setwd(choose.dir())

Salvare il dataframe come file



Importare dati in R

Lavoreremo molto più spesso in questa modalità



Spesso si usano fogli di calcolo in wide format, con dati inseriti a mano o esportati da un altro 

programma. R importa dati da file di molti formati diversi, ma noi lavoreremo con dati da file 

in formato .txt (o formato .csv).

Per aprire un file in formato .txt si usa read.delim().

Se non diversamente specificato, R si indirizza alla cartella in cui è stato installato:

Trucco per evitare il percorso del file: 

dataframe<-read.delim(file.choose(), 

header=TRUE)

Analogamente, per aprire un file .CSV, useremo la funzione read.csv().

Aprire archivi di dati esterni

Il dataframe 

avanti_tabulato
è creato leggendo il file in formato 

delimitato da tabulazioni
che è così identificato 

nel computer

e in cui la prima riga 

costituisce l’intestazione 

delle colonne



Dalla Data scegliete Import Dataset → From Text File

e poi usate le finestre per individuare il file da importare.

Il corrispondente comando viene stampato in Console; nella finestra Data compare il

nome del dataframe e si apre la finestra Visualizza.

Importare dati con RStudio

Una finestra di Preview consente di individuare eventuali errori nell’importazione.

Errore nell’intestazione delle colonne, 
che R interpreta erroneamente come 

prima riga dei dati: tutte le variabili sono 
importate come character, ed è loro 
assegnato un nome di default (V1, V2, 

V3…). 

Controllate sempre 

Heading: Yes eche

Strings as factor 

sia spuntato,



Per creare variabili e dataframe, si può usare il menu Dati→ Nuovo set di dati;

Per lavorare su dataframe esistenti, nel menu Dati si sceglie Importa dati,

specificandone il formato (.txt, .xls). Se è un dataframe su cui si è già lavorato, si sceglie più

rapidamente utilizzando l’icona Set di dati, scegliendo poi di visualizzarlo (Visualizza

i dati) o di modificarlo (Edita i dati):

Modificare e creare dataframe con RCommander



Questo è l'essenziale 
per iniziare a lavorare

Vedremo diverse altre operazioni con o sulle variabili e i 

loro elementi quando ne avremo necessità, nelle prossime 

lezioni


